You are here

RB750P-PBr2 4 node POE switch

14 posts / 0 new
Last post
nc8q
nc8q's picture
RB750P-PBr2 4 node POE switch

Solved, finally.

I would like to add nodes to a limited access site where it is awkward to add additional ethernet cables.
I bought a Mikrotik RouterBoard RB750P-PBr2 Power Box over 16 months ago.
Today I discovered how to configure this box to be an outdoor POE powered 5 port node switch with pass-through POE.
I am using the POE port (ether1) as DtD downlink with 4 ports for nodes.
I have 4 devices POE powered and DtD connected to a NODE port of a GS108Ev2 managed switch.
To simulate a real world environment to test voltage drop I have
Ubiquiti 24 volt 1 amp (gigabit) POE injector
50 feet of CAT5E ethernet cable to the Power Box
50 feet " to a Nanoloco M2
100 feet " Nanostation M9
100 feet " Nanostation M3
50 feet " Nanostation M3

This appears to be working. YMMV.

Configuration of the Power Box is a 1 line, 7 word, 74 character file.
Starting with a reset of the Power Box:
I ftp'ed the 1 liner to the /flash directory of the Power Box.
(I used Filezilla. Flash memory is retained after a 'reset'.)
I hooked a computer to port 5 of the Router Box.
I viewed http://192.168.5.1 on the web browser of the computer
The browser auto-logs-on with no 'admin' password (default).
Click on the 'Terminal' button near the top right of the screen.
Enter "import flash/1.txt" (without the double quotes).
Voila!

Reference: https://wiki.mikrotik.com/wiki/Vlans_on_Mikrotik_environment

Chuck

File Attachment: 
AJ6GZ
Voltage

What resultant voltage is the Mikrotik reporting with all 4 nodes powered on?

I've used the PowerBox quite a bit (it's just a HeX POE in an outdoor case) but have always given it power on the DC jack if more than one downstream device. Good someone decided to test the limits!

Ian

nc8q
nc8q's picture
Voltage measurements

The stock supply is 24 volts @ 2.5 amps.
I didn't find the stock power supply and used an old laptop supply, 19 volts @ 4.74 amps.

Setup:
Power supply -> 118' CAT5 -> Power Box, then 50 or 100 feet CAT5 feeding the nodes:
With 4 nodes, NS-M9, NS-M3, NS-M3, locoM2; the 19 volts drops to 15.4 volts (at the Power Box) with total draw ~970 ma.
I assume the Power Box pulls 100 ma so the total draw on the PS is ~ 1070 ma.

(This setup fails with the Ubiquiti 24 volt, 1 amp POE injector; Power Box reporting 'short circuit'.
Ditto with 18.5 volt old laptop supply.
Only the locoM2 and one of the NS-M3s would work with these supplies.)

Apparent milliamp draw increases with lower power supply voltage.
This may be a 'switching power supply' issue.
Need to test this setup with stock power supply.

Chuck


 

nc8q
nc8q's picture
Found original power supply

Labeled: 24 volts at 2500 ma
No-load: 24.3 volts
Loaded : 21.1 volts at ~830 ma, ~730 ma (4 nodes) + ~100 ma Power Box, with above cabled setup.
:-)

AJ6GZ
Port 1

I'm not sure what port 1's max current rating is. The specs are kind of hazy but people on the forums say around 1A. It looks like you are right at the limit of "normal" PoE of 15.4W. To get full power to all ports you can use the round DC port, but I know you are trying to avoid extra cable. If the RJ45 circuitry can't handle it I guess you could split off the PoE and feed it into the DC jack.

In any case, I would look at an adjustable 24V supply to offset that 20% voltage drop and lower the current. I use models like this in various settings:

https://www.meanwell.com/webapp/product/search.aspx?prod=HDR-60 (27.6V max) https://www.meanwell.com/webapp/product/search.aspx?prod=RS-75 (29V max)

Ian

nc8q
nc8q's picture
Just for grins I added 2 more nodes.

Just for grins I added 2x NS-M5s.
Setup:
Stock power supply rated 24vdc @ 2500ma -> 118' CAT5 -> Router Box ether1
ether2 -> 100' CAT5 NS-M3
ether3 -> 50' CAT5 NS-M3
ether4 -> 50' CAT5 NS-M5 -> 6' CAT5 -> locoM2
ether5 -> 50' CAT5 NS-M5 -> 6' CAT5 -> NS-M9

NS-M3, NS-M3, NS-M5, NS-M9 set for minimum TX power, locoM2 WiFi client, NS-M5 WiFi AP.
Sum of 4 ethernet ports draw ~ 1000ma for 6 nodes and are sent 20.3 vdc from Power Box.

CAT6E may have less voltage drop and lower apparent current.

Chuck

nc8q
nc8q's picture
Regulated by voltage at load

I suggest that, if one wishes to provide 24vdc to the Power Box with an external power supply,
get one with separate terminals for 'sense remote voltage'.
(I've used these in an industrial setting back in the second millennium. Are they still being made?)
Use one pair from ethernet cable (4,5)(7,8) to send power and another pair to return actual voltage at the Power Box.
This would provide regulated 24vdc at the Power Box under varying load.

Chuck
https://community.keysight.com/community/keysight-blogs/general-electron...
https://www.acopian.com/single-l-goldboxb-o.html
Next, find one we want to afford.

 

VA2XJM
Remote Management

@nc8g Have you found a way to make the web management gui accessible from the mesh ?

Ether1 is going down the tower to a hAP AC Lite port 5 (VLAN2)
Ether2-5 are nodes on the tower.

Ether5 is the «main» node that is available to assign an IP to the web gui.

I tried many configuration, but can't figure it out.

nc8q
nc8q's picture
web management gui accessible from the mesh ?

Never even thought about this. Management gui is still available offline, statically at 192.168.88.1.
I was satisfied with it being an appliance.

Chuck

VA2XJM
Goal here is to control the

Goal here is to control the power options (power cycle nodes, disable «Ping timeout power cycle» when updating firmware....) without having to have another piece of software runing. So web gui is good for that...

However, using the above (OP) command I am able to bridge everything so nodes are DtDing... But I have really hardtime to make VLAN working and attaching the web gui to VLAN...

Will check the tutorial again tonight and makes it through Winbox... I wish to have it working by the end of the weekend so it can be deployed next weekend.

AJ6GZ
IP

It is possible to attach the PowerBox's management interface to any of the bridges/vlans it is connect to. On mine, I just add it to one of the AREDN LAN bridges and it is accessible. The IP can be static or DHCP. If you do static also remember to add, on the IP Routes page, a static route to 0.0.0.0 to your gateway. If using DHCP I've had, on occasion, the MAC address change upon boot since it is attached to a virtual bridge. This may throw off the DHCP reservation you have assigned on the node. To statically set the MAC, use the "Admin MAC Address" field on the bridge interface and it will always keep that same one. Just use the one it came up with on its own. It won't try to reuse it on another interface during boot if you lock it in.

You might also try the Winbox software. It can connect at layer 2 with a MAC address only, or by regular IP address. It is superior to the web browser screen in my opinion anyway.

Ian

VA2XJM
Can you provide a bit more

Can you provide a bit more information ? I am not used to Mikrotik devices that I can see offer more options and possibilities...

However If I follow your tutorial, I get the following error, see the screenshot.

Image Attachments: 
AJ6GZ
Bridge

Do you have a bridge created for the AREDN VLAN? It should attach to that ok.

Ian

VA2XJM
My bad it now attach...

My bad it now attach...
What I had to do is to check "VLAN Filtering" in "bridge-vlan10" -> VLAN tab. Otherwise the DHCP client was not connection.
It is now working! thanks for your help.

Switch is now setuped to host 4 nodes.

For references:

/interface bridge
add fast-forward=no name=bridge-vlan1 vlan-filtering=yes
add fast-forward=no name=bridge-vlan2
add admin-mac=B8:69:F4:B1:61:32 auto-mac=no fast-forward=no name=bridge-vlan10 pvid=10 vlan-filtering=yes
/interface ethernet
set [ find default-name=ether3 ] poe-out=forced-on
set [ find default-name=ether4 ] poe-out=forced-on
set [ find default-name=ether5 ] poe-out=forced-on
/interface vlan
add interface=ether1 name=ether1-vlan1 vlan-id=1
add interface=ether1 name=ether1-vlan2 vlan-id=2
add interface=ether2 name=ether2-vlan1 vlan-id=1
add interface=ether2 name=ether2-vlan2 vlan-id=2
add interface=ether3 name=ether3-vlan1 vlan-id=1
add interface=ether3 name=ether3-vlan2 vlan-id=2
add interface=ether4 name=ether4-vlan1 vlan-id=1
add interface=ether4 name=ether4-vlan2 vlan-id=2
add interface=ether5 name=ether5-vlan1 vlan-id=1
add interface=ether5 name=ether5-vlan10 vlan-id=10
add interface=ether5 name=ether5-vlan2 vlan-id=2
/interface bridge port
add bridge=bridge-vlan1 frame-types=admit-only-vlan-tagged interface=ether1-vlan1
add bridge=bridge-vlan2 frame-types=admit-only-vlan-tagged interface=ether1-vlan2 pvid=2
add bridge=bridge-vlan1 frame-types=admit-only-vlan-tagged interface=ether2-vlan1
add bridge=bridge-vlan2 frame-types=admit-only-vlan-tagged interface=ether2-vlan2 pvid=2
add bridge=bridge-vlan1 frame-types=admit-only-vlan-tagged interface=ether3-vlan1
add bridge=bridge-vlan2 frame-types=admit-only-vlan-tagged interface=ether3-vlan2 pvid=2
add bridge=bridge-vlan1 frame-types=admit-only-vlan-tagged interface=ether4-vlan1
add bridge=bridge-vlan2 frame-types=admit-only-untagged-and-priority-tagged interface=ether4-vlan2 pvid=2
add bridge=bridge-vlan1 frame-types=admit-only-vlan-tagged interface=ether5-vlan1
add bridge=bridge-vlan2 frame-types=admit-only-vlan-tagged interface=ether5-vlan2 pvid=2
add bridge=bridge-vlan10 frame-types=admit-only-untagged-and-priority-tagged interface=ether5 pvid=10

/interface bridge port
add bridge=bridge-vlan1 frame-types=admit-only-vlan-tagged interface=ether1-vlan1
add bridge=bridge-vlan2 frame-types=admit-only-vlan-tagged interface=ether1-vlan2 pvid=2
add bridge=bridge-vlan1 frame-types=admit-only-vlan-tagged interface=ether2-vlan1
add bridge=bridge-vlan2 frame-types=admit-only-vlan-tagged interface=ether2-vlan2 pvid=2
add bridge=bridge-vlan1 frame-types=admit-only-vlan-tagged interface=ether3-vlan1
add bridge=bridge-vlan2 frame-types=admit-only-vlan-tagged interface=ether3-vlan2 pvid=2
add bridge=bridge-vlan1 frame-types=admit-only-vlan-tagged interface=ether4-vlan1
add bridge=bridge-vlan2 frame-types=admit-only-untagged-and-priority-tagged interface=ether4-vlan2 pvid=2
add bridge=bridge-vlan1 frame-types=admit-only-vlan-tagged interface=ether5-vlan1
add bridge=bridge-vlan2 frame-types=admit-only-vlan-tagged interface=ether5-vlan2 pvid=2
add bridge=bridge-vlan10 frame-types=admit-only-untagged-and-priority-tagged interface=ether5 pvid=10

 

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer