You are here

Bug in recent nightly build on RouterBoard - found my narrative!

7 posts / 0 new
Last post
W2TTT
W2TTT's picture
Bug in recent nightly build on RouterBoard - found my narrative!

Hi Folks!
Love the new RouterBoard implementation, but there may be some fixes needed.
I brought it up with the 2 GHz mesh node and 5 GHz AP running.
worked fine, except that the node would only show its IP address in the mesh status of its neighbor and was not shown anywhere else, which makes sense for a node with no name to share.
Then I changed it to have the mesh node off and went to a 2GHz AP.

This is where things got nuts.  I was rebooting the RB and its neighbor to no avail.  It still would not display its name on the neighbor.  In the process of changing AP bands in an attempt to fix this, I also observed that the AP wouldn't present its SSID, but that I would see an SSID of "MeshNode".  This appears whether I had the AP on 2 or 5 GHz.
Eventually, I got the AP back by activating the 2 GHz mesh node with a 5 GHz AP.  I then turned off the 2 GHz mesh node and moved the AP successfully to 2 GHz, albeit with the "MeshNode" SSID still there.  At least the OLSR was working well and presenting the name and It was being propagated.

One other point... when switching the AP from 2 GHz to 5 GHz the default channel of 36 comes up.  When going the other way, there is no change or even a choice of channels 1-11.  One only sees 5 GHz channels.  If one then saves it, the channel options do change.  Upon selection of the desired 2 GHz channel followed by a save and a reboot, the changed configuration goes live +/- the troubles I mentioned above.

Enclosed are two support files.  I hope that they help.
73,
Gordon Beattie, W2TTT 
201.314.6964
 

AE6XE
AE6XE's picture
OLSR bug issue #

Gordon,  

Issue 1 -  IP address showing in mesh status for a node

refer to:  https://github.com/aredn/aredn_ar71xx/issues/204

OLSR is configured correctly, but not propagating the hostname across the mesh.  Because it is intermittent, I'd speculate it is a timing bug in OLSR.   The symptoms are such that this node shows up with an IP address in mesh status on other mesh nodes.  The work around is to do this command:

"/etc/init.d/olsrd restart"

You can put this command  in "/etc/init.d/olsrd/local"  to force olsr restart just after the node is booted, to avoid this condition.

Issue 2:   UI behavior for the LAN AP settings

Here's the issue...  The current code since BBHN days has all the UI logic on the server side.   The UI does not handle dependent selections very cleanly.  It's really a hack for now until we re-write the UI with a modern framework.   For example, to change the "AP band" setting, you will have to click the 'save changes" button first, then the UI is updated and has the correct "Channel" options.    Once you save the settings, with an inconsistent band and channel #,  a message pops up, "Configuration NOT Saved!, Changed to 2GHz Mesh LAN AP, please review channel selection".  The reverse from 2 to 5GHz shows as well.   I  had decided not to spend the time to rewrite this logic in javascript and run on the client side to improve the usability in the current architecture.   I'd rather spend the time to replace the current UI.  

I didn't find any evidence of a "MeshNode*" SSID in the support dumps.  The live and config settings  show one wireless interface disabled and the other configured with custom AP settings.   (one of the data files was 3.18.9.0, out of scope. maybe I don't have the smoking gun data file?)  Once settings are successfully saved, do a reboot and validate the state of the node.   On firstboot, both MeshNode2G and MeshNode5G  SSIDs are live LAN Access points, until a successful save settings and reboot of the node.

Joe AE6XE

W2TTT
W2TTT's picture
OLSR Bug

Joe,
Here is an error that I received.

cd
/etc/init.d/olsrd restart
olsrd: /etc/init.d/olsrd: olsrd_setup_smartgw_rules() Warning: kmod-ipip is missing. SmartGateway will not work until you install it.

73,
Gordon, W2TTT
201.314.6964

 

AA7AU
AA7AU's picture
Same on 3.18.9.0

Interesting, I see same result on stable release 3.18.9.0 on a Rocket M2 after approx 20 sec delay.

- Don - AA7AU

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

  3.18.9.0, r7258-5eb055306f
 ----------------------------------------------
root@W7HEN-HARC-M2R90-TDY:~# /etc/init.d/olsrd restart
olsrd: /etc/init.d/olsrd: olsrd_setup_smartgw_rules() Warning: kmod-ipip is missing. SmartGateway will not work until you install it.
root@W7HEN-HARC-M2R90-TDY:~#



 

AE6XE
AE6XE's picture
Gordon,  try the latest

Gordon,  try the latest nightly build.  I had submitted changes a couple days ago to clean up some of the OLSR warnings we were seeing.  This message is harmless as the SmartGateway functionality is not being used (but may be used in the future).

Joe AE6XE 

AB4YY
Not propagating hostname nor service name

We have the following nodes:

  • W3IF-LHG5-161 (FW v.1010-8177bab) (Mikrotik XL HP 5)
  • NO4N-500 (FW v.1010-8177bab) (Ubiquiti Bullet 5 Ghz)

Both nodes have Iperfspeed installed.

When W3IF is rebooted, we see two problems:

  1. The node name is not propagated to the network (NO4N is the only neighbor).
  2. The W3IF Iperfspeed advertised service disappears not only from the network but also on W3IF itself.

I can resolve the issues by running "/etc/init.d/olsrd restart" on W3IF.  (Running "/etc/init.d/olsrd restart" on NO4N does not fix either issue.)

This problem and fix is repeatable.

Maybe this report will help with this apparently known issue.
73 - Mike ab4yy

K6CCC
K6CCC's picture
This has been happening once

This has been happening once in a while for a while.  It is being talked about over on the github.
https://github.com/aredn/aredn_ar71xx/issues/431
 

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer