You are here

Nightly Build 1623-696df41 Broke it.

4 posts / 0 new
Last post
KE6GYD
KE6GYD's picture
Nightly Build 1623-696df41 Broke it.

I decided to try the nightly build 1623-696df41 on 8-16-22.  Updated a PBE-M5-400-ISO from 3.22.6.0 release.   Device is at end of 50' ethernet at my QTH going through a Netgear GS-108e Switch, it was Node 2 dtd'd to my local node via the switch.   I updated Node 2 through the switch and the nightly came back updated.  

I have another PBE-M5-400-ISO as Node 1 in the switch that is my local node:8080 that is also on my roof on a 50' ethernet.
 
So I updated my local node through the switch as I did the first one.  After update process finished, could not bring up the local node. No link light after seconds of a few flashes.  Then the first node I updated stopped working.  No link lights for both after some initial boot up flashes.
 
Thought maybe it was the switch.  Tried another switch, no success. Thought maybe it was the 12 to 24volt converter I was using to power the nodes using the "Y" type injectors at my Netgear switch. Did the nightly's require more power?

I eliminated my switch and went direct from a node to computer using a standard Ubiquiti  PoE AC Power supply injector.   Was able to bring up the node.

With the direct connection to computer, was able to Convert back to 3.22.6.0 release.  Connected it back to my Netgear system switch with the original power setup and it worked again.  Connected the other unit in my system  that still had the nightly along with the working one, still nothing on the nightly unit.  The link lights flashed for a bit, then went dead. 

I was able to convert the 2nd unit back to 3.22.6.0 release with a direct connection to computer. Connected it back to my system and both are working just as they did before I updated to the nightly.

This one is a head scratcher.

73
Bob
KE6GYD
 

AB7PA
Which image did you try?

Bob, which firmware image did you use when you did the upgrade?  It might also help to know the board_id of your units which would be in the support_data file or sysinfo.json output.

PowerBeam-M5-300 ar71xx loco-m-xw 64Mb stable
PowerBeam-M5-400/400ISO/620 ar71xx rocket-m-xw 64Mb stable
KE6GYD
KE6GYD's picture
Nightly Build 1623-696df41 Broke it.

The image was yesterdays nightly for the Rocket-M-XW.  1623-696df41  Also tried today's nightly and same result.  So units are back to the Stable Release 3.22.6.0 and working fine.

Wondering why the nightly's wouldn't work with the Switch?  Maybe a switch setting that conflicted with a change in the Nightly's?  Again, all is working fine with 3.22.6.0.

0xe6e5 is the board.

Thanks
Bob
 

AB7PA
Can you capture a support_data file after the upgrade?

After installing the Nightly Build firmware, are you able to ping the node from your connected computer?  If so, I wonder if you could capture a support_data dump and post it.  It's difficult to tell what's going on without a little more info.  Even if you can't get to the upgraded node's web interface you might be able to generate the support_data file using this direct link in your computer's browser -- http://your-nodename-or-ip/cgi-bin/supporttool

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer