You are here

New to VOIP

11 posts / 0 new
Last post
KC2MVB
KC2MVB's picture
New to VOIP

Hello All,

  So as the subject says I'm new.  But I'm also new to mesh so double whammy!

  I have 3 nodes (a 4th one but it's USB and use it when I'm away from home to connect to my mesh network).  Main node is the MikroTik hAP AC Lite (dual band) from the supported list.  Two CPE-210's v2.8.  The mesh network has been working fine.  I have one (1) Raspberry Pi connected in which acts as my MeshChat server, Apache for web stuff and then Synchronet BBS for the fun of it.

  So with luck I was able to get two (2) Grandstream PXP2160 phones from ebay and they are working.  I finally was able to get them upgraded with Grandstream's latest firstware (took forever to figure that one out).  So these are up-to-date.

  Bought another Raspberry Pi v3 b+) for my PBX.  Using Raspberry-asterisk.org version for the PBX software.  After multiple attempts that is now updated with the latest greatest version I can get it to: FreePBX 15.0.16.49

  So now comes my dilema.  I cannot remember for the life of me if I was able to get audio between the two phones by dialing the extension numbers or not.  If I dial direct via I.P. I can talk back and forth all day long.  Phone A calls Phone B and then B calls A.  Great.  Direct dial by I.P.

  The problem is by extension.  Going through the PBX.  So I clearly have it setup incorrectly.  Everywhere I turn it's "NAT causing the problem" and fix NAT and NAT this and NAT that.  We are not doing NAT on these that I was aware of.  But if we are then how does one change things?  I have been reading to keep NAT off to help prevent further issues.

  And on that note...  Raspbx is plugged into the Mikrotik along with one phone.  The other phone is plugged into another node (CPE210).  I was beginning to wonder if the different 10.x.x.x addresses might be the cause but direct dial via IP works.  So I guess it comes down to NAT.  Ugh.

  What am I missing?  What other info do you all need?  I used the lastest stable version of AREDN firmware and then a nightly build not long ago.  Can't remember which one I'll have to look that up.  MikroTik: v 1491-831df9a

Thanks.  I am learning a lot about VOIP now but without audio back and forth via PBX I'm kind of dead in the water.  And since I'ms uing the FreePBX version on here manual configuration files aren't always an option.

73, Dean, KC2MVB

KG5UHV
one question, from raspberry

one question, from raspberry can you ping both telephones? I assume asterisk
is setting up the voip call, it may not be true. You can run tcpdump or wireshark
in raspberry and see how the call is being setup.


 

KC2MVB
KC2MVB's picture
Ping Successful

Hello.  Thanks for your response...  Pinging is a success.  I am looking up tcpdump and wireshark now.  Wireshark is installing so once I look that over I'l run it and see how things look.

Thank you for these two pieces of software.

73, Dean

KG5UHV
wireshark has a way to build

wireshark has a way to build the "ladder" that makes the connection, taken from asterisk host will show
the two legs of the connection.

This is from top of my memory, one you capture the traffic with phone call, under Telephony you will find
"Sip Flows", that will identify the calls present in capture, then you will have to select one of them and you
will be able to plot the ladder with each message, if only rtp is failing, check ip addresses and ports.
 

KB9OIV
The phones must have a web

The phones must have a web interface--is there an indication that the phones are 'registered' or online with pbx?

KB9OIV
Also, in the pbx admin

Also, in the pbx admin interface, look at:

settings>asterisk log files

If your phones are 'online', then you might be able to find some hints from the logs

KC2MVB
KC2MVB's picture
Thanks all

I was going through both wireshark and tcpdump.  I was looking at port 5060 specifically.  The phones are there.  They are registered.  They show the ring and answer etc.  But that's it. No audio.  This is so strange.

Is there a way to show the entire port span for audio using either of these two programs?  I even went so far last night to plug the other phone into the MikroTik just to be eliminate the different segment portion.  Same issue so that wasn't it.

I did notice though it kept coming up with an error about *97 not registered.  So I clearly have something programmed wrong.  I'm just not sure which end I guess.


KB9OIV, Yes, via the web page on the phones they do show connected and online with the PBX.

Dean

KB9OIV
Lets try some changes to SIP

Lets try some changes to SIP on your PBX.

From Admin page:

Settings>Asterisk SIP settings

At General SIP Settings Tab:
ADD Local Networks: 10.0.0.0 / 8

At Sip Legacy Settings Tab:
NAT: NO
IP Configuration: Public

Click "Submit" at the bottom, and finally "Apply" (Red button) at the top.


 

KB9OIV
To me, the "*97 Not

To me, the "*97 Not Registered" means your phones are not actually talking with the PBX.  The 'Not Registered' is your phone telling you that it cannot reach the configured server.

KB9OIV
Also, did you create

Also, did you create 'extensions' for each phone on your PBX, at Applications>Extensions?
 

KC2MVB
KC2MVB's picture
ALL FIXED

Hello folks...  Thanks for your responses...  You might not believe it but watching another video I learned a command.  WOW!!

fwconsole restart

After I did that all is working!  TO include voicemail calling / setup.  SO..  With all of the changes I did I forced the restart by logging in via SSH and forcing restart.  I'm learning some other commands also....

asterisk -rvvv --> that is r v v v (space it out so it won't get confused with a w. :)  This right here..  Just like a tcp dump or wireshark but real time of everything the system is doing.  This is awesome!!!!!  Yes this via SSH also. sorry.

fwconsole ma upgradeall -> upgrades everything.  ma = module admin.

Just an FYI for anyone who did not know.

I'll be back to testing now!!!!!!

73, Dean

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer