You are here

Meshchat 1.02 node and rpi configuration ??

7 posts / 0 new
Last post
K3MMB
Meshchat 1.02 node and rpi configuration ??

trying to get MC 1.02 installed and working on tp-link210, hap ac and rpi.

I can get the two nodes to talk nice, but the rpi just will not sync up.

I have edited the config file on the rpi, but have not it right yet.

I can start MC on the rpi, enter identifier/callsign. The send message screen displays.

the MC zone matches the name from the node/ It says it is a rpi install, but does not show msg entered on node.
trying to send from rpi get 'could not get lock' error.

assisted is definitely needed.

best regards
mike

K5DLQ
K5DLQ's picture
Did you install the MeshChat

Did you install the MeshChat API package on a node?
Also....
https://www.arednmesh.org/content/pi-meshchat-error-sending-message

K3MMB
installed api on tp-link 210v2, but not
K5DLQ
K5DLQ's picture
The API package is installed

The API package is installed on the node that your RPi is configured to point to.  The "lock" fix (around comment #18) is done on the RPi

K3MMB
still no joy on rpi

Thanks,

the lock fix did not do the trick. I think I will just start the rpi from scratch.

nodes play nice as it is.

thanks for the info
regards
mike

K3MMB
progress, I think

started with fresh RPI install. 

loaded meshcaht 1.02
did edits for lock
synced names of zone on two nodes and rpi

the rpi sees all messages sent from the nodes
the nodes only see messages sent from the other node.

also looking for how to delete messages.

regards
mike

K5DLQ
K5DLQ's picture
not an easy way to delete

not an easy way to delete message since they are "network persistent".   This is by design.
The only way is to shutdown all MC instances in the same zone, delete the message files from the filesystem, restart them back up.
 

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer