You are here

Loading firmware on TP Link CPE210 V2.8

21 posts / 0 new
Last post
K4TTZ
Loading firmware on TP Link CPE210 V2.8

I have posted this in the Hardware group also in hope of some help.  I have two TP Link CPE210 v2.8 radios that I am hoping to run the AREDN firmware on.

I have tried all variations of software available for download without success.  I am however quite good at recovery to the PHarOS native firmware.  Nothing seems to help and all I get is a constant reboot cycle in which all lights except power cycle ever 15secs. or so.

Any insight would be greatly appreciated.

Wayne
K4TTZ

AE6XE
AE6XE's picture
K4TTZ,  a small change is

K4TTZ,  a small change is needed in the AREDN firmware before it will load.   shortly...

AA7AU
AA7AU's picture
Fingers crossed

I just bought a new CPE210 from Amazon and surprise surprise ... the label on the box which arrived two days ago says v 2.8 - guess it will stay plastic wrapped so I can return it to Amazon if there are going to be issues with it being usable sometime soon. Thanks for the heads-up and keeping me from getting all tangled up in it as well. Thanks to Joe and the team for the upcoming "small change".

- Don - AA7AU
 

AA7AU
AA7AU's picture
Any news on CPE210 v2.8?

I am about to return this unit to Amazon if it's not likely that I can get it up and running on-line soon. Is this something that will wait on 3.20.3.1?

TIA,
- Don - AA7AU

AE6XE
AE6XE's picture
Don, Wayne,  can you ssh into

Don, Wayne,  can you ssh into the device with Pharos OS running and capture the output of this command, below?   The usual method of finding all the product string options is not bearing fruit.  We usually do a strings command on the Pharos .bin to find all the flavors, but not seeing any 2.8 strings.  We can at least add in to the AREDN image, the string from your devices, which is necessary so our image will be accepted. 

dd if=/dev/mtd2 bs=1 skip=4360 2>/dev/null | head -n 1 | tr -d '\r'

[edit]  refer to this link, more dialog to collect this information:  https://www.arednmesh.org/content/tplink-cpe210-will-not-program

The output would look something like one of these, but have the 2.8 version:

CPE210(TP-LINK|EU|N300-2|45550000):3.0
CPE210(TP-LINK|UN|N300-2|00000000):3.0
CPE210(TP-LINK|UN|N300-2):3.0
CPE210(TP-LINK|EU|N300-2):3.0
CPE210(TP-LINK|EU|N300-2):3.0
CPE210(TP-LINK|EU|N300-2|45550000):3.1
CPE210(TP-LINK|UN|N300-2|00000000):3.1
CPE210(TP-LINK|US|N300-2|55530000):3.1
CPE210(TP-LINK|EU|N300-2|45550000):3.20
CPE210(TP-LINK|UN|N300-2|00000000):3.20
CPE210(TP-LINK|US|N300-2|55530000):3.20

Joe AE6XE
AE6XE
AE6XE's picture
Don, should be able to look

Don, should be able to look at this within the next week.  It is a straight forward change.

Joe AE6XE

ng1p
ng1p's picture
upgrade my CPE-510.

I was not able to upgrade my CPE-510. The last version does work fine. I assume the .1 release will also fix this one also? All other devices upgraded fine, Nanostation M5 and Rocket M5. BTW the CPE-510 is working just fine on the older version 3.19.3. 

Thanks

AE6XE
AE6XE's picture
ng1p,  what version v1.x, v2

ng1p,  what version v1.x, v2.x, v3.x?  "not able to upgrade" -- please describe, it reboots as if nothing happened?  It loads the 3.20.3.0 firmware, but then doesn't boot?  other?

 

ng1p
ng1p's picture
Sorry Here is the details

I was assuming it was the same issue. This is a CPE-510 ver 3.8. I got this about 1 month ago and was able to load ver 3.19.3.0 and is working fine. When trying to upgrade to 3.20.3.0 (doing so via direct connection or over the mesh network) I get the following error:
"Bad Gateway
The process did not produce any response"
So it starts the download (done this via upload Firmware and Download Firmware) options and get the above error message in the browser. I refresh the page and I'm back at the Admin screen and the upgrade stops and leaves me at version 3.19.3.0.

Thanks Bill NG1P 


 

ng1p
ng1p's picture
sysupgrade also fails

I see that others when seeing this error use the command line option but this also fails:

root@NG1P-15:~# sysupgrade -n aredn-3.20.3.0-ar71xx-cpe510-v3-sysupgrade.bin 
Image metadata not found
Unsupported image (model not in support-list)
Image check 'platform_check_image' failed.

KK4ZUZ
If you are sure that its the

If you are sure that its the right device and you know how to recover using the recovery process  try the following to force it to load
sysupgrade -v -n -F aredn-3.20.3.0-ar71xx-cpe510-v3-sysupgrade.bin

ng1p
ng1p's picture
Sounds risky

I think I will hold off until the next release. Its working fine right now at 3.19.3.0 and I'd rather not turn this into a brick if I don't have to.

KK4ZUZ
K4TTZ What version of the

K4TTZ What version of the AREDN software are you trying to load? Is it the very latest release as older versions will probably not work on the TP Link CPE210 v2.8. For that device you will need the very latest version.

AA7AU
AA7AU's picture
WIll return

Going to return my shrink-wrapped v2.8 CPE210 to Amazon as it needs to work pretty much out of the box, Thanks for all.

- Don - AA7AU

ps: still struggling with an old CPE220v3 on NB#1394 and now with almost no flash space = no tunnels etc - will post details when time available, right now the earth is shaking here at 6.5 with 14 aftershocks

AA7AU
AA7AU's picture
Amazon impact - tertiary and beyond

Amazon has started to delay shipping and 2-day Prime has gone the way of social contact. One silver-lining I just found is that Amazon has now extended the "Return Eligible" date on my CPE210 v2.8 node out another month, so I'm going to keep it for a while longer in the hopes that this issue will get fully resolved before then. My apologies for not wanting to "unwrap" it to help with the testing as I can't afford to keep this myself ($$) if it's not going to work out of the box for the intended agency's use.

Thanks for everyone else's work on this - sorry to be such a cry-baby,
- Don - AA7AU

KC2MVB
KC2MVB's picture
CPE210 arrived early

I ordered two of these new units from Amazon and they arrived 2 days early!  After reading this thread should I wait to attempt to flash them?

I can use them for my home network if I can't use them for AREDN so no loss on my part.  Or should I go ahead and attempt to see if it does work?

AE6XE
AE6XE's picture
KC2MVB,  we're in need of

KC2MVB,  we're in need of someone confirming the model string on the vendor flash of the device.     Are you familiar with ssh details to log in to to Pharos OS and do these commands?   

Here's an example of the string we are looking to find on the device:
CPE210(TP-LINK | US | N300-2 | 55530000):2.0

This command should give us the string:
cat /dev/mtdblock2 | grep -i CPE210

See this link-thread, a prior discussion on this same issue:
https://www.arednmesh.org/content/tplink-cpe210-will-not-program
 
Joe AE6XE

KC2MVB
KC2MVB's picture
Joe,  Here is what I got when

Joe,  Here is what I got when I ssh into the unit.  Is this what you needed?

$ cat /dev/mtdblock2 | grep -i CPE210
CPE210(TP-LINK|US|N300-2|55530000):2.0
product_name:cpe210
$

73, Dean, KC2MVB

KC2MVB
KC2MVB's picture
All Good!

Joe,
  I am happy to report I have a MESH NETWORK!!!!

  I hadn't heard back from anyone so I thought today since I had a few mins. I would attempt to load up my two CPE-210's.  Worked like a champ!  I have a basic mesh network now! :)  It's not doing anything but but I can see the other node!

  So these are two TP-Link CPE-210's are from Amazon.  V2.8.  The second was giving me grief with the pharoah software upon initial start up.  It didn't take the AREDN software first try but I just changed my answer to keep and loaded fine.

  If you need any other info. from these let me know.  I have a router coming in at some point so when that happens I'll load it and connect it all up and see where I get.

73, Dean, KC2MVB
 

AE6XE
AE6XE's picture
Dean,  thanks for the update.

Dean,  thanks for the update.  Can you confirm, this was the 3.20.3.0 image you up loaded within Pharos OS UI?:

http://downloads.arednmesh.org/releases/3/20/3.20.3.0/targets/ath79/gene...

Joe AE6XE

KC2MVB
KC2MVB's picture
Confirmed

It was in fact the latest build. My apologies for not stating that.

Dean, KC2MVB

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer