You are here

3.22.1.0 problems when upgrading

6 posts / 0 new
Last post
KQ6EO
3.22.1.0 problems when upgrading

Having many problems upgrading firmware to 3.22.1.0 on Ubiquiti Nanostation and Rocket XM hardware.  Either the upgrade will not load and/or tunnels will not come back up after upgrade.  Is anyone else having these problems?
 

K6CCC
K6CCC's picture
No NanoStations here, but

No NanoStations here, but four Rocket M3 XM and two Rocket M5 XM without issue.  The two M5s also have tunnel firmware installed and that is working fine.  The other end of the tunnels were a late nightly in a hAP, and then the hAP was updated to 3.22.1.0
 

AJ6GZ
XM

Don't know if your Nano is XM or XW, but my last remaining Nano XM has to be off-mesh to upgrade anymore due to memory issues. Preferably turn off RF (frees more RAM) and DtD, or perhaps at least change the RF channel. I do not use tunnels on that node, so I don't know if that's an issue too.

My XW Nano's upgrade no problem.

On a side note my BaseBox2 was slightly unstable after upgrading. It would crash during a Meshchat API upload. Another power cycle seemed to clear that up and the api and tunnel sw then loaded no problem.

NM7B
Concur: NanoStations can be temperamental

I have a mix of NanoStations and Rockets, and concur: the NanoStations are temperamental when I attempt to update them, especially remotely.  Most require multiple attempts before the updates occur.  Sometimes they need an extra reboot to make the update stick.  I had a couple go into a zombie state where I saw the link state oscillate with the adjacent nodes.  In one case I could telnet in and issue a reboot command.  After two went into this state, I performed all but one of the remaining NanoStations while hardwire-connected to the NanoStation's LAN jack.  Even then, I had one today that stuck in the flashing red LED state for too long.  After telnet'ing in and issuing a reboot, the subsequent attempt succeeded.

The Rockets I have updated without a hitch (don't remember which version I have--or both).  

k6dlc
k6dlc's picture
  I am glad to others are

  I am glad to see others are having issues with there Nano upgrade. I have tried four times and with no success. That is with both Sysupgrade and Full install.

nc8q
nc8q's picture
Upgrading to 3.22.1.0
MikroTik RouterBOARD 952Ui-5ac2nD ! hAP Unplugged WAN and DtD. Took about 4 tries to upgrade.
MikroTik RouterBOARD LHG 5HPnD    Easy peasy
MikroTik RouterBOARD LHG 5HPnD-XL "
MikroTik RouterBOARD LHG 5HPnD-XL "
MikroTik RouterBOARD LHG 5HPnD-XL "
MikroTik RouterBOARD LHG 5nD      "
MikroTik RouterBOARD RBLHG-5HPnD  "
MikroTik RouterBOARD RBLHG-5HPnD  "
MikroTik RouterBOARD RBSXTsq5HPnD "
MikroTik RouterBOARD RBSXTsq5HPnD "
MikroTik RouterBOARD SXTsq 5HPnD  "
MikroTik RouterBOARD SXTsq 5HPnD  "
MikroTik RouterBOARD SXTsq 5HPnD  "
MikroTik RouterBOARD SXTsq 5HPnD  "
MikroTik RouterBOARD SXTsq 5HPnD  "
MikroTik RouterBOARD SXTsq 5nD    "
Ubiquiti Bullet M (firmware)      " NanoBridge and NanoStation M9. Took a few tries and not linked to 60+ node network
Ubiquiti Loco M XW                " 
Ubiquiti Loco M XW                "
Ubiquiti Nanostation M3 (2x)      Took a few tries and not linked to 60+ node network
Ubiquiti Rocket M XW (firmware)   PowerBeam M5 400. Easy peasy.

Overall, the 32 MB RAM devices and the hAP were reluctant to accept the sysupgrade.

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer