You are here

MikroTik Router Board hAp lite flashing issues

9 posts / 0 new
Last post
K7SDW
MikroTik Router Board hAp lite flashing issues

I have tried several times to flash the hAp like ac (RB952Ui-5ac2nD-US) and keep getting bad results wit the 3.19 load.

factory reboot is back when I follow their reset. and RB.ELF loads with the normal page, but the device does not consistently give me a 192.168.1.1 to begin the first step of seeing the NOCALL page.  When I get it I put in my call, password, and distance, save and it auto re-boots, but after I set to DHCP I sometimes get the factory settings of 192.168.88.1
So I do not get back to the local.mesh:8080 setup at all.

I got as far as attempting to upload the firmware, and I got the following display.
Greg




 

File Attachment: 
k1ky
k1ky's picture
MikroTik Router Board hAp lite flashing issues

Sounds like you are missing the step of loading the "permanent" Firmware image.  Do this next before populating and changing settings. 

KD1HA
KD1HA's picture
...and uncheck keep settings!

...and uncheck keep settings!

KG7GDB
Elf is only temporary; Setup-> Administration->Update is next

The PXE server causes a remote bootup of the Mikrotik using a temporary firmware rb.elf file.
This gives us access to the AREDN setup and administration page.
You "trick" the device to update itself by uploading the real AREDN firmware sysupgrade bin file.

From the documentation:
In a web browser, open the node’s Administration page http://192.168.1.1/cgi-bin/admin (user = ‘root’ password = ‘hsmm’) and navigate to the Setup > Administration > Firmware Update section. Select the bin file you previously downloaded and click the Upload button.

As KD1HA stated above, uncheck "keep settings," then reboot to "update" to the real firmware.
After the reboot, you can enter your real node settings as shown in Basic Radio Setup section of documentation

The documentation can be a bit confusing to read. I have only done two Mikrotik hAP devices, but was successful both times. You can do it!
73, Brett
 

K5DLQ
K5DLQ's picture
BTW, If anyone has

BTW, If anyone has suggestions on making the docs less confusing, we would love to hear them.
 

K6CCC
K6CCC's picture
One doc update needed

Here's one - and it had nothing to do with the hAP - but rather with Ubiquiti.
Please update the TFTP procedure on this page: https://www.arednmesh.org/content/tftp-firmware-installation
The Windows TFTP client does not work the way it is described on that listed page.  It is actually a single command line that is needed.
 

K5DLQ
K5DLQ's picture
awesome!  thanks for noting

awesome!  thanks for noting that.
We've updated that page to point everyone to the official AREDN documentation.  

(that page was an older one before we started the full documentation project).

Thanks!

 

AE6XE
AE6XE's picture
I recommend using the nightly

I recommend using the nightly build image for the hAP ac lite as of today.   All prior firmware versions,  the 5GHz driver consumes RAM to the point the device can become sluggish and in some cases stop functioning.    Fortunately, this has not been a significant issue to use day to day.  However, when doing a sysupgrade (installing a new AREDN firmware on top of AREDN already installed), this can be problematic if not running the new nightly build image.  The sysupgrade process needs a lot of RAM.

Joe AE6XE

AK4FA
New HAP AC Lite

I ordered a new US version off Amazon last week and it came with 6.46.4 and it didn't have enough free resources to take the ELF, it always booted back to the Microtik OS. To get the upgrade to complete, this is what I did. (Requires Windows)

  • Download NetInstall 
  • Download RouterOS 6.43.16 for MIPSBE
  • Follow the instructions for NetInstall 
  • When you get to the step where you browse for the file to load, choose the RouterOS 6.43.16 file you downloaded in the above step
  • After reboot make sure you can get to the new RouterOS on 192.168.88.1 and it shows the correct version
  • Follow the regular instructions https://arednmesh.readthedocs.io/en/latest/arednGettingStarted/installing_firmware.html
  • If you use the tinypxe server on windows make sure you have closed out of NetInstall and set the manual ip back to 192.168.1.10 or you'll get a conflict
  • Once the ELF is up, and you change ports from port 1 to port 2, upload the nightly BIN (Don't use the stable release it failed several times for me)
  • I've never had luck with recent hardware to use the browser load, instead I switch to my mac and do
  • scp -P 2222  <the .bin file name>   root@192.168.1.1:/tmp/rb.bin
  •  Now log into the device, "telnet 192.168.1.1"   user = 'root' password = 'hsmm'. 
  • Then type   "sysupgrade -n /tmp/rb.bin"    wait for it to reboot, now it has AREDN installed and you can go in and set it up.  Be sure to renew your IP address after it reboots.  

I hope this helps, I had tried disabling the WIFI interface and that still caused errors, I even used winbox to remove the wifi package on router OS with no luck.

-Andrew AK4FA

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer